Installation Collabora Online

#1

Bonjour,
j’utilise ouvaton depuis bien longtemps mais c’est la première fois que je post.
J’essayer d’utiliser nextcloud pour moi et mes collègues, j’en ai donc installé une version sur mon site sans problème.
Je voudrais installer collabora online pour que cela convienne parfaitement a notre usage. Mais là… je bloque. D’après ce que j’ai compris il faut installer collabora sur un autre sous-domaine mais c’est pour l’installation que je ne sais pas comment faire, il n’est pas question sur les tuto d’uploader des fichier comme pour nextcloud et hop ça marche…
Si l’un-e d’entre vous l’a déjà fait je suis preneur de conseils.
Merci d’avance
Nico

#2

Bonjour,

Collabora n’est il me semble pas installable sur un hébergement mutualisé comme celui d’Ouvaton.

Je regarde dès que j’ai du temps comment on peut le rendre accessible aux Nextcloud installés chez nous.

#3

Bonjour,

Y a-t-il du nouveau sur ce point ?

Merci.

#4

Bonjour,

Un Collabora est installé et testé en ce moment sur https://collabora.ouvaton.coop/.

Voulez-vous l’utiliser ? J’ai besoin de connaître l’URL du Nextcloud à ajouter (en MP si besoin) pour l’autoriser au niveau de notre Collabora.

Il faut de votre coté activer dans Nextcloud l’application dans Applications/Bureautique et Texte/Collabora Online/Activer. Il faut ensuite indiquer l’adresse https://collabora.ouvaton.coop/ dans Administration/Collabora en ligne.

#5

Bonjour,
Je veux bien l’essayer sur mon nextcloud
https://www.lejasduvignal.fr/partage/
merci !

#6

Ça devrait être utilisable dès maintenant dans votre Nextcloud.

#7

Voici le message qu’il m’affiche lorsque je rentre l’adresse dans les parametres:

Sauvegardé avec une erreur : Collabora Online devrait utiliser le même protocole que lors de l’installation du serveur.

#8

Bonjour,

Êtes-vous bien connecté en HTTPS à votre Nextcloud lors de l’ajout de l’URL de Collabora ?

#9

c’était ça, ca marche, merci beaucoup !

#10

Moi aussi je veux bien :wink: adresse de mon nextcloud en MP

#11

Bonjour,

Voilà l’adresse ajoutée, vous devriez pouvoir utiliser Collabora dès maintenant !

#12

Merci Matthieu !

#13

Bonjour,
Je viens d’essayer, je suis bien en https sur mon cloud et pourtant j’ai la même erreur que NicoD “Sauvegardé avec une erreur : Collabora Online devrait utiliser le même protocole que lors de l’installation du serveur”.
Et lorsque j’essaie douvrir un document j’ai ceci
"Erreur interne du serveur
Le serveur est incapable d’exécuter votre requête.
Si cela se reproduit, veuillez envoyer les détails techniques ci-dessous à l’administrateur du serveur.
Le fichier journal du serveur peut fournir plus de renseignements.
Renseignements techniques
Adresse distante : 192.xxx.yyy.zzz
ID de la demande : ****************"

Je n’ai rien ds mes logs, je suppose donc que c’est le log du serveur collabora. Si tel est le cas, avec l’adresse “distante” qui est celle locale de de ma box je trouve ça étrange
Je suis un peu parano peut être :smile: mais je ne mets pas l’ID de la demande sur le forum.
S’il y a trop de traffic sur le serveur collabora de ouvaton et donc trop de log, je l’envoie en MP

Ah oui : je suis en Nextcloud 13 depuis quelques jours

Merci
CLaire

#14

je m’auto réponds car … le log est bien chez moi ( au temps pour moi … mon log est sur une machine virtuelle sur un serveur à distance, et l cnx pas tjours très rapide … :slight_smile: ).
Bref, voici ce que j’ai ds mon log,
… “Message”:“cURL error 1: Protocol \”%20https\" not supported or disabled in libcurl …

donc je vais oeuvrer … la balle est dans mon camp.
Merci encore pour tout
CLaire

#15

re auto réponse à mon auto réponse : pour ceux qui veulent rire … quand j’ai copié/collé l’url de collabora, il y avait un blanc devant :smiley: :smiley:

et merci +++ à ouvaton pour cette mise à disposition de collabora !

#16

Bonjour,
Je suis également intéressé pour utiliser Collabora ; est-il possible d’ajouter www.bourgault.fr/data ?
Merci d’avance !
Joël

#17

Bonjour,

Voilà l’adresse de votre Nextcloud ajoutée !

#18

Bonjour,

Merci pour l’ajout de mon site, mais hélas, ça ne fonctionne pas encore : j’ai bien mis https://collabora.ouvaton.coop/ en tant qu’adresse du serveur Collabora, mais quand je souhaite ouvrir un document, j’ai l’erreur suivante :

En allant chercher un peu dans la documentation de Nextcloud, j’ai bien trouvé ceci, mais ça ne m’éclaire pas vraiment :

Troubleshooting

(…)
Issue: I get connection errors when trying to open documents
Be sure to check the error log from docker (docker logs id-of-your-instance). If the logs note something like:

No acceptable WOPI hosts found matching the target host [YOUR NEXTCLOUD DOMAIN] in config. Unauthorized WOPI host. Please try again later and report to your administrator if the issue persists.

you might have started the docker container with the wrong URL. Be sure to triplecheck that you start it with the URL of your Nextcloud server, not the server where Collabora Online runs on.

Une idée sur la manière de corriger cela ?

#19

Bonjour,

J’ai ajouté www.bourgault.fr comme indiqué, mais vous accédez à votre site avec l’adresse bourgault.fr (sans www.).

Quelle adresse utilisez-vous (avec ou sans www.) ?

#20

Ah ah ! C’est correct, et je viens tout juste de m’en rendre compte : je me connecte toujours, par habitude, à mon nextcloud par l’adresse https://bourgault.fr/data, c-à-d. sans le www.

Je viens d’essayer en me connectant à https://www.bourgault.fr/data/, et là, plus d’erreur d’hôte WOPI ! :slight_smile:

Du coup, serait-il possible d’ajouter cette adresse, sans www., à la liste des domaines autorisés ?

Merci pour le coup d’œil !