Problème avec l'installation de NextCloud

#1

Bonjour,
Je me tourne vers la communauté car je ne parviens pas à disposer d’une instance fonctionnelle de NextCloud sur mon espace web.

Dans un premier temps, j’ai utilisé la procédure décrite ici : https://ouvaton.coop/Installer-Nextcloud-sur-Ouvaton. Tout se passe bien, c’est même plutôt rapidé. Je configure NextCloud pour qu’il utilise MySQL, j’indique comme répertoire de l’application “nextcloud” (j’ai d’abord essayé avec “partage”). J’indique comme répertoire de données un dossier nommé “ncdata” à la racine de httpdocs.
Après l’installation, si je veux supprimer des fichiers, j’ai le message “Problème de chargement de la page, réactualisation dans x secondes”…
J’ai modifié les permissions via FTP (mises à 777, quelle horreur !). Tout pareil : ça ne fonctionne pas.

Ce matin, je viens de déposer la version 12.05 via FTP, me disant que la version 13 avaient besoin de prérequis non réunis. Même chose : ça ne fonctionne pas.

Comment faire ?

Bonne journée

#2

Bonjour,

La version 13 fonctionne correctement sur la plateforme. Vous avez déposé les fichiers d’une 12.05 par FTP en écrasant les fichiers de la 13 ?

Il n’est pas nécessaire de modifier les permissions, par défaut vous avez la possibilité de lire/écrire partout sur votre espace.

#3

Merci de votre réponse.
À chaque tentative j’ai à chaque fois supprimer les fichiers de l’installation précédente et supprimé les tables dans la base de données.
Je ferai une autre tentative d’installation quand j’aurais un moment.

#4

Bonjour,
Je viens de refaire une tentative d’installation de NextCloud sur un sous-domaine de poitiersec.org, histoire de m’affranchir d’une configuration qui ne conviendrait pas sur le sous-domaine du blog.
J’ai toujours le même problème, à savoir lorsque je veux supprimer un fichier : “erreur à la suppression de…”, puis "problème de chargement de la page…"
À la déconnexion, j’ai ce message d’erreur : “Accès interdit CSRF check failed”.

Je viens d’essayer avec Chromium : même problème lors d’un essai de suppression, puis après aucun. Par contre même message d’erreur à la déconnexion.
Lors du dépôt d’un fichier de 15Mo : “internal server error”, c’est peut-être normal (limitation côté serveur ?). Même chose avec un fichier de 5Mo, mais au final le fichier apparaît…

Je ne vois pas quoi faire.

Merci si quelqu’un a une idée.

#5

Bonjour,

Le problème est de notre coté (un effet de bord de l’arrivée de PHP 7 sur la plateforme). Je viens de faire remonter à notre infogérant.

#6

Bonjour,
Je remarque avoir le même problème que cité plus haut:
A chaque ouverture de page, nextcloud me dit “probleme de chargement, rechargement dans 5 secondes”, et fini par ouvrir la page en question.
Lorsque je charge un fichier: “CSRF check failed”, puis “rechargement (idem que ci-dessus)”, puis ça finit par marcher.
A la deconnexion: “Access forbidden - CSRF check failed”.
Au niveau de l’installation, j’ai suivi la procédure du tutoriel. Les fichiers sont stockées dans un dossier hors-nextcloud, à la racine, et je suis passé par mySQL.

Est-ce pareil pour tout le monde ?
Quelqu’un a-t-il trouvé une solution a ce probleme ?
Merci d’avance pour vos réponses et bonne après-midi,
Adrien

#7

Bonjour,

Je viens de faire une installation. Apparemment ça passe maintenant.
Si vous voulez que j’essaye sur votre compte, ouvrez un ticket d’assistance.

#8

Bonjour,
Merci pour votre réponse, je viens d’ouvrir un ticket d’assistance.
Pensez-vous nécessaire que je tente une ré-installation ?
Merci d’avance,
Adrien

#9

Bonjour,

NextCloud opérationnel. Néanmoins, après installation de la version 13, c’était très lent. J’ai installé une version 12 que j’ai mise à jour ce matin, tout fonctionne. L’appli Android également.
Je continue à tester avant de proposer aux utilisateurs de mon association.

#10

Bonjour,
J’ai réinstaller nextcloud 2 fois aujourd’hui:

  • avec le webinstaller: toujours le meme problème
  • en dechargeant le package version 12. En version 12 pas de souci (a part une étiquette qui dit qu’il y a un probleme de sécurité, une faille dans le code). Je suis passé en version 13 (update), et rebelote avec la situation décrit plus haut.