Forum Ouvaton dans le tableau de bord de Nextcloud

Bonjour,

Je souhaiterais ajouter les flux du Forum Ouvaton dans mon Tableau de bord de Nextcloud.

J’ai installé l’appli Application > Tableau de bord > Discourse integration

  • Sur le Tableau de bord je clique sur Se connecter à Discourse

  • Comme adresse de l’instance je définie https://forums.ouvaton.coop (sans / final autrement il sera doublé dans le lien) puis je clique pour me connecter

  • Le forum me propose d’ajouter l’application :

forum1

forum2

Sur la page de configuration il est écrit :

Si vous n’arrivez pas à accéder à votre compte Discourse, votre instance Discourse n’est probablement pas autorisée à donner des clés API à votre instance Nextcloud.
Demandez à votre administrateur Discourse d’ajouter cette URI à la liste des allowed_user_api_auth_redirects dans les options d’administration :
web+nextclouddiscourse://auth-redirect

Est-ce que ce serait possible @MatthieuPatout s’il te plaît ?

Par avance merci :kissing_heart:

C’est fait, est-ce mieux maintenant ?

Je n’ai plus le message d’erreur mais je reste bloqué sur la page Autoriser l’application. Je clique sur Autoriser et rien ne se passe.

Peut-être c’est mon Firefox qui bloque quelque chose, je vais redémarrer sans module.

EDIT : Aucun changement en désactivant les modules, je clique sur Autoriser, ça lance le sablier une seconde et ça reste sur la page.

Je ne maîtrise pas bien l’outils Console de Firefox mais quand je clique dessus je trouve :

Navigation vers « https://forums.ouvaton.coop/user-api-key » empêchée en raison d’un protocole inconnu.

POST
https://forums.ouvaton.coop/user-api-key
État 302 Found
Version HTTP/2
Transfert 5.77 Ko (taille 0 o)
Politique de référent strict-origin-when-cross-origin
Priorité de la requête Highest

Je ne sais pas si ça pourra aider, je suis un peu newbie avec cet outils :child:

Visiblement l’application Discourse Integration ne propose pas au navigateur (testé avec Firefox et Brave) d’ajouter la gestion du protocole web+nextclouddiscourse://auth-redirect, du coup il ne sait pas quoi faire de l’URL de redirection pour valider la connexion.

1 Like

En fait si, avec Brave au moins, via une minuscule icône dans la barre d’adresse. :slight_smile:

Une fois le protocole ajouté, ça fonctionne :

1 Like

Est-ce que tu pourrais montrer une image de cette minuscule icône ?

Je n’ai pas Brave, j’essaie aussi avec Chromium mais je ne vois rien de plus :cry:

Je t’ai envoyé beaucoup de :heart: :grin:

Est-ce qu’il est possible d’ajouter ce protocole manuellement à Firefox ?

Pour Brave l’icône est dans la barre d’adresse, sur la droite, juste avant le bouton de partage.

Avec Firefox tu dois avoir, dans Paramètres → Général →Fichiers et Applications → Applications, une ligne comme ci-dessous :

La ligne web+nextclouddiscourse vient s’ajouter après avoir autorisé l’application via la petite barre qui va apparaître sous la barre d’adresse de Firefox, comme le montre l’application dans Nextcloud.

Par contre sur le Firefox que j’utilise, j’ai du faire Aide → Plus d’informations de dépannage →Réparer Firefox (attention ça RAZ la config de Firefox) pour voir la barre s’afficher et pouvoir autoriser, et il faut encore ensuite bien sélectionner l’adresse du Nextcloud dans Applications. Après ça c’est ok :

ncdisinc2

Il doit bien y avoir moyen de modifier ces applications dans Firefox, mais je ne sais pas comment.

1 Like

Merci beaucoup @MatthieuPatout pour le temps que tu m’as consacré.

Alors j’ai cherché partout dans about:config et dans pref.js, et j’ai finalement trouvé le problème que j’avais avec Firefox et Chromium : J’étais en navigation privée :male_detective:

Dès que j’ai désactivé l’option j’ai bien vu le bandeau s’afficher sous la barre d’adresse.

Merci beaucoup :kissing_heart:

1 Like