Quid de WordPress + WooCommerce + WPML hébergé chez Ouvaton

Bonjour,

Je suis en train de créer un site marchand pour une proche, créatrice de décoration d’intérieur. J’ai choisi WordPress pour la base, WooCommerce pour la partie e-commerce, et probablement WPML pour traduire le site en anglais, une petite partie des ventes s’effectuant déjà vers des pays anglophones.
Le tout serait peut-être à saupoudrer d’une extension de cache comme WP Rocket, si les « performances » ne sont pas satisfaisantes.
All In One WP Security pour sortir couvert, et Yoast SEO pour le référencement.

J’étais curieux de voir si le forum d’Ouvaton contenait des discussions à ce sujet, mais une recherche de « WooCommerce » ou « multilingue » ne retournent rien. Les mentions de « commerce » ou « ecommerce » sont anciennes et peu nombreuses.

Bref : y a-t-il une quelconque restriction à utiliser Ouvaton pour mon projet ? Performances ? Contraintes techniques ? Autres ?

Merci ! :slight_smile:

Bonjour,

À ma connaissance, aucune restriction !

Les performances de la plateforme web sont satisfaisantes depuis plusieurs années. Nous rencontrons peu d’erreur 50x depuis plusieurs mois suite au travail de notre infogérant.
Le site devrait bien fonctionner sans avoir à ajouter un plugin de cache.
Un point non cité qui me vient à l’esprit est l’utilisation d’un plugin comme WP Mail SMTP pour l’envoi des mails depuis le site. Il n’est pas recommandé de passer par la fonction mail() de PHP, moins fiable sur notre plateforme.

Un retour d’expérience une fois le site en place depuis quelques semaines serait chouette ! :slight_smile:

Voilà qui est encourageant. :slight_smile:

C’est justement sur ce site en construction que j’ai déjà rencontré le problème, donc c’est au programme.

Avec plaisir. :slight_smile:

Concernant WPML spécifiquement, leur site internet liste plusieurs pré-requis :

  • WordPress 4.7 or later
  • PHP 5.6 or above with memory limit of at least 128MB while 256MB is recommended (see WP memory settings). Keep in mind that the required memory for your site depends on your content, theme and all plugins.
  • That you can create tables in your database.
  • WordPress REST API must be enabled for WPML to function properly.

Ci-dessus, c’est bon. Ci-dessous, j’ai un doute :

Pour les trois premières, j’apprécierais vos lumières. :slight_smile:
Pour la dernière, WooCommerce installé sur mon site en création indique 5.5.5-10.1.43-MariaDB-1~stretch pour la version de MySQL. Est-ce qu’une mise à jour est possible, à la manière des versions de PHP ?

Merci !

Bonjour,

mbstring et simplexml sont disponibles, tout comme eval() .

La version de MariaDB est 10.1.43. :slight_smile:

Superbe. :slight_smile: