Problème mises à jour site WP

Bonjour,

Pas possible de faire la MàJ de mon site depuis environ une semaine (thème+extensions).
La maintenance ne finit pas. Le message affiché est « problème serveur interne ».
Je me demande si ce n’est pas depuis que j’ai fait la mise à jour PHP.

Pouvez-vous m’aider?
Merci d’avance !

Bonjour,

Vous pouvez essayer de repasser en PHP 7.4 pour voir si le problème persiste avec cette version.

Il faut également vérifier via une connexion FTP si un fichier nommé .maintenance est présent dans le répertoire httpdocs/. Si oui il faut le supprimer pour sortir Wordpress de sa maintenance.

1 Like

Ok merci je vais essayer ça. Mais il faudra bien mettre PHP à jour non ?
Pour la maintenance, je fermais l’onglet et après qq temps ça déconnectait le site et annulait la maintenance ; j’essaierai via ftp si besoin.

1 Like

La version de PHP est bien modifiée maintenant.
Vous pouvez faire les mises à jour, puis si tout est ok repasser votre site en PHP 8.1.

Les mises à jour se déroulent mieux en PHP 7.4 ?

1 Like

J’ai pu faire la mise à jour sans problème en 7.4. Pourquoi ça bloquait en PHP 8.1 ?

D’après d’autres expériences pour d’autres CMS, lorsque qu’un CMS est sur une version qui supporte la version 7.4 de PHP, mais qui ne supporte pas encore totalement une version supérieure de PHP, alors, la mise à jour de cette version du CMS doit se faire avec la version PHP compatible, soit ici 7.4. Souvent la mise à jour du CMS (ou la mise à niveau, c’est à dire un changement de version), intègre la compatibilité avec une version supérieure de PHP (ici, 8.0 ou 8.1), et devient fonctionnel avec cette version supérieure de PHP.

Ici, ce doit être vraisemblablement le cas.

1 Like

Ok, merci pour l’explication. Comment je peux savoir quelle version de PHP est supportée par WP du coup ?

1 Like

Wordpress propose une page avec les prérequis pour sa dernière version : Prérequis | WordPress.org Français

Un tableau plus complet est disponible en PHP Compatibility and WordPress Versions – Make WordPress Core.

1 Like

Super, merci pour les liens :slight_smile:

2 Likes

Bonjour à toutes et à tous,
j’ai eu un problème similaire, pour un nouveau site réglé sur PHP 8, impossible de l’installer en français, puis un fois installé en anglais impossible de faire la MaJ en français.
Je suis repassé à PHP 7, comme le conseillait Mathieu, cela a fonctionné.
J Charles

2 Likes