Pb d'affichage en https

Bonjour,

J’ai créé 2 sites avec wordpress. Seul celui ayant un nom de domaine propre (tokapu-films.org) s’affiche correctement en https. L’autre (attac-montpellier.ouvaton.org) ne s’affiche pas correctement en https.

D’autre part, un autre site que j’ai créé il y a maintenant plusieurs années avec textpattern (eau34) a aussi le même problème d’affichage en https.

Comment y remédier ?

Merci de votre aide.

Pour le Wordpress en attac-montpellier, avez-vous regardé la page https://ouvaton.coop/certificat-ssl/ ?
Forcer HTTPS partout sur le site devrait résoudre le problème.

Pour eau34, la page https://forum.textpattern.io/viewtopic.php?id=48729 donne des informations.
Je viens d’ajouter le .htaccess et le ligne define('PROTOCOL', 'https://'); dans le fichier config.php, et le site s’affiche correctement. Il reste du contenu mixte (fichiers en HTTP et d’autres en HTTPS.

Bonjour,

Pour le site eau34, tout marche impec après correction pour le contenu mixte. Merci.

Pour le site attac-montpellier, j’ai modifié .htaccess et wp-config.php comme indiqué. J’accède bien maintenant au site en https. Mais j’ai le message d’erreur “Désolé, vous n’avez pas l’autorisation d’accéder à cette page.” lorsque j’essaie de me connecter à l’administration du site. La modification des urls du site en https dans la config de wordpress ne change rien, pas plus que la suppression des cookies du cache.

Je ne sais plus trop quoi faire.

Bingo !!!

Il faut que la modif de wp-config.php soit juste après <php et non pas à la fin du fichier comme je l’avais fait initialement.

Maintenant, c’est tout bon.

1 Like