Paramétrage de Nextcloud sur Ouvaton - Bonus avec Français par défaut et économe en espace disque

Bonjour,

Je me permets de faire un message récapitulatif ici de tout ce que j’ai dû paramétrer sur mon Nextcloud pour le rendre le plus fonctionnel possible, en fonction des contraintes liées aux paramétrages serveurs Ouvaton.

Il demeure néanmoins le bug aléatoire de déconnexion, mais nettement moins fréquent en démarrant sur l’agenda.

Testé sur Nextcloud 21.0.1

Fichier /httpdocs/.htaccess (à la racine), ajout des lignes suivantes :

Cliquer pour agrandir et afficher
# Redirection vers HTTPS
RewriteCond %{HTTPS} off
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
# Redirection de www.cloud.*votresiteinternet.com* vers cloud.*votresiteinternet.com*
RewriteEngine On
RewriteCond %{HTTP_HOST} ^www\.(.+) [NC]
RewriteRule ^ https://%1%{REQUEST_URI} [L,R=301]

[…]

Header always set Strict-Transport-Security "max-age=15768000"
Header always set Referrer-Policy "no-referrer"

Fichier /httpdocs/config/config.php, ajout des lignes suivantes :

Cliquer pour agrandir et afficher
  'trusted_proxies' => 
  array (
    0 => '10.0.20.16',
  ),
  'forwarded_for_headers' => 
  array (
    0 => 'HTTP_X_FORWARDED_FOR',
  ),

[…]

  'tempdirectory' => '/var/www/vhosts/*votresiteinternet.com*/httpdocs/data/tmp',
  'defaultapp' => 'calendar',
  'default_language' => 'fr',
  'default_locale' => 'fr_FR',
  'default_phone_region' => 'FR',
  'enable_previews' => false,
  'memcache.local' => '\\OC\\Memcache\\ArrayCache',
  'trashbin_retention_obligation' => 'auto, 7',

Attention de bien respecter la casse (minuscules et majuscules) pour les fr et FR, autrement ça ne fonctionne pas !

Dans ces lignes j’ai désactivé les aperçus et programmé le vidage des corbeilles au bout de 7 jours pour limiter l’espace disque utilisé chez Ouvaton.

Désactiver les espaces de travail riches qui créent des fichiers en erreur de synchronisation (readme.md) :

Cliquer pour agrandir et afficher

Pour remettre le paramètre par défaut : config:app:set text workspace_available --value=1

Si des fichiers sont verrouillés (« File is locked » ou « Server replied : 423 Locked ») :

Cliquer pour agrandir et afficher
  • Passer le site en mode maintenance via le fichier /httpdocs/config/config.php :
    'maintenance' => true,

  • Se connecter à la base SQL via PHPMyAdmin, sélectionner la base de données et exécuter la requête SQL :
    DELETE FROM oc_file_locks WHERE 1

  • Quitter le mode maintenance via le fichier /httpdocs/config/config.php :
    'maintenance' => false,

Et voilà :slight_smile:

Je n’ai pas encore réalisé de mise à jour donc je n’ai pas encore d’éléments que j’ai pu tester à ce sujet. Mais dès que c’est fait je reviens ici compléter mon sujet.

Bon Nextcloud à toutes et tous,
Camille.

2 Likes

Merci pour ces propositions de modifications … j’ai essayé … J’ai modifié comme proposé les fichiers .htaccess et config.php
hélas le résultat n’est pas probant… c’est quasiment impossible de ce connecter quel dommage!
Coopérativement
Michel

Ah mince, pourtant cela fonctionne bien chez moi. Quel est le problème que cela génère ? Quel message d’erreur ?

Bonsoir,

J’ai testé les modifs sur config.php - arrivée sur agenda par défaut - sur un NC 20 avec pas mal d’utilisateurs, et effectivement, pour l’instant, ça fonctionne: il y a une TRES nette amélioration.

Peut-être un problème de cache: au départ, avec Firefox, il me semblait y avoir aucun avantage, puis en essayant avec un autre navigatuer, ça fonctionnait. Après « vidage » du cache Firefox: impec aussi sur Firefox.

Phil Cherp

1 Like

Merci pour vos réponses
Ayant lu il y a quelque temps le post de MacGyver j’ai suivi ses conseils et je me suis connecté directement sur Calendar j’ai alors noté une nette amélioration de la connexion
Hier les accès à NextCloud étaient catastrophiques j’ai donc essayé de modifier .htaccess et config.php comme préconisé et cela a apporté un changement de réaction (la page « calendriers » s’affichait mais les calendriers eux même ne s’affichaient pas ?) Je suis revenu aux anciennes versions de .htaccess et config.php et je ne suis jamais arrivé à me connecté depuis mon PC de bureau qui tourne sous Ubuntu… mais j’ai réussi à me connecter sur mon PC portable qui tourne sous Windows (D’une façon générale j’ai l’impression que les connexions sont plus facile sous Windows (Dans les deux cas j’utilise Firefox).
Ce matin Mon téléphone et Thunderbird sous Ubuntu me demande de redonner mon mon de passe NextCloud … mais ne l’accepte pas ?
Par contre je suis arrivé à me connecter sans problème à NextCloud depuis mon PC Ubuntu ???
Je vais arrêter et redémarrer mes PC et mon téléphone et voir comment tout cela se comporte.
Cela fait plusieurs mois que j’utilise NextCloud et que mes calendriers, contacts, notes …Thunderbird et Téléphones sont synchronisés… c’est absolument superbe! Je vais bien arrivé à retrouver ce niveau de fonctionnalité!
Coopérativement
Michel

Ayant tout arrêté et relancer j’arrive à me connecter à NextCloud depuis Firefox… Et Nextcloud fonctionne correctement
Par contre toute connexion par l’intermédiaire d’une application reste impossible:
Erreur de connexion
Merci pour vos aides
Coopérativement
Michel

Bonsoir !

je viens de ré-installer l’appli sur mon ordi Linux (Magéia), et tout fonctionne parfaitement…
De même sur un ordi avec Win.
Je ne peux donc pas aider, car chez moi, tout fonctionne…

Coopérativement,
Phil Cherp

Merci
Je suis moi aussi dépassé… j’ai l’impression que c’est une session qui ne se ferme pas…
J’ai mis un post au support
Merci encore
Coopérativement
Michel

Bonjour à toutes et tous,

Comme promis je viens compléter mon message initial.

Ayé, je viens de réaliser ma première mise à jour de Nextcloud hébergé sur Ouvaton avec le Web Updater. Mise à jour réussie avec succès et sans aucune erreur !

J’ai pris mes précautions au préalable, comme retrouvé, expliqué et solutionné dans différents sujets sur ce forum. Aussi je tiens ici à remercier particulièrement @MatthieuPatout et @PhilCherp pour leur participation plus qu’active à la recherche de solutions efficaces aux demandes, problèmes et difficultés que nous pouvons rencontrer :pray: :slightly_smiling_face:

Fichier /httpdocs/config/config.php, ajout temporaire de la ligne suivante (par sécurité je la retire une fois la mise à jour terminée) :

Cliquer pour agrandir et afficher

'integrity.check.disabled' => true,

Fichier /httpdocs/updater/index.php, modification du bloc suivant (vers la ligne 482) :

Cliquer pour agrandir et afficher
		$excludedElements = [
			'.rnd',
			'.well-known',
			'data',
			'3rdparty',
			'apps',
			'core',
		];

Ce qui correspond à l’ajout des 3 lignes suivantes :

			'3rdparty',
			'apps',
			'core',

J’ai ensuite lancé la mise à jour dans le menu Paramètres > Administration > Vue d’ensemble.

À la fin de la mise à jour j’ai obtenu l’écran suivant :

Puis en cliquant sur le bouton « Disable maintenance mode and continue in the web based updater » pour désactiver le mode maintenance, j’ai basculé sur une autre page de mise à jour pour mettre à jour la base de données SQL et les applications telle que :

J’ai continué sur Nextcloud et tout était à jour et en bon état de fonctionnement.

Il faut tout de même penser ensuite à refaire les modifications dans le fichier .htaccess comme expliqué dans le premier message de ce sujet.

Et faire attention à l’espace disque utilisé après une mise à jour !
Après chaque mise à jour un sous-dossier est créé dans le dossier /httpdocs/data/updater-"suite de lettres et de chiffres aléatoires"/backups/
Vous pouvez garder le dernier backup si vous le souhaitez mais comme la plupart des fichiers sont exclus de la sauvegarde, vous pouvez aussi supprimer les sous-dossiers à l’intérieur du dossier backups une fois que votre mise à jour est réussie et fonctionnelle.

Merci beaucoup à Ouvaton, à son équipe et à ses utilisateurs-trices et longue vie ! :metal:
Camille.

2 Likes