L'authentification, le php, le code, le maire et la médiathèque

Faut il changer une partie de son code pour avoir accès par php à l’authentication ?
j’imagine donc que c’est dû à une nouvelle version de php
si j’avais su j’aurais modifié le code avant de migrer
mais je n’ai lu nul part que ouvaton3 changerait quelque chose à ce niveau là
C’est bien dommage pour moi

Regarde cette faq: http://aide.ouvaton.org/Qu-est-ce-qui-change-avec-le-PHP.html

Par ailleurs, je ne comprends pas très bien la question: est-ce une question d’accès à une base de données (auquel cas il faut regarder du côté du nom du serveur MySQL qui a changé) ou autre chose? Pour MySQL: http://aide.ouvaton.org/Les-bonnes-adresses.html

Coop,
Greg

Bonjour,

Je ne suis pas sûr non plus de comprendre la question.
J’émets une hypothèse… Il s’agit d’une authentification de type : WWW-Authenticate: Basic realm=“xx” pour protéger une partie d’un site, le php de la nouvelle plate-forme étant en mode cgi, il est nécessaire de modifier celle-ci. Un exemple non testé ici : http://www.phpcs.com/codes/WWW-AUTHENTICATE-AVEC-PHP-MODE-CGI_30656.aspx

Ayant la partie d’un sitequi utilisait ce type d’authentification, j’ai préféré - après quelques tests infructueux - en revenir à des méthodes différentes :

Mais je suis peut-être à côté de la question ???

Christian.