FTP (Dreamweaver)

je n’arrive pas à placer mes fichiers avec Dreamweaver. “placer” reste grisé…

Il faut dire que, bien qu’ayant bien renseigner les champs suivant:
nom du serveur: ftp.ocsa-data.net

  • nom de l’utilisateur: www.tondomaine.tld
  • mot de passe: **** (mot de passe associé),
    puisque je vois mes fichiers de mon site, il me manque à renseigner “répertoire hôte”. tondomaine.tld comme répertoire ne marche pas.

C’était MON hypothèse pour expliquer ma panne mais si vous pouvez m’aider…

Laurent

Normalement, si tu donnes www.tondomaine.tld comme nom d’utilisateur pour le ftp, le répertoire hôte devrait être simplement «html» (sans les guillemets). Le mieux pour tester, c’est de ne pas donner de répertoire hôte, de regarder où on tombe et de voir ce qu’il faut ajuster…

Coop,
Greg

justement ! je n’ai rien mis dans hôte et je tombe bien sur mon site…

mais je n’arrive pas à foutre des fichiers et puis y’a des pbs de connexion FTP, alors je me disais que ça venait deu non-renseignement de la ligne hôte…

j’ai Dreamweaver 8.
L.

Laurent, bonjour

Il faut juste mettre “/” sans les guillemets.

Ok, effectivement ce n’est pas plus mal. au moins je sais maintenant que mon pb ne vient pas de là.

Je n’arrive pas à placer mes fichiers sur mon site. PLacer, synchroniser, archiver, je ne connais pas bien la différence.

Ma question est en fait liée au logiciel que j’utilise et non plus maintenant au ftp. Vous me dire si elle a bien sa place ici.

coopérativement,

Laurent

PS pour Esther: hic rodus hic salta ! (en référence à la phrase de sa signature numérique : “sauter par dessus le gouffre”).

Quelque soit le problème dans le cadre des usages numériques en lien avec la coopérative, vos questions sont bienvenues.

Dans dreamweaver, si mes souvenirs ne sont pas trop flous, vous avez la possibilité de tester les infos pour la connexion ftp. Pouvez vous précisez ce qui se passe ou ne se passe pas quand vous sélectionnez un fixhier.html et que vous essayer de le copier sur votre espace web, dans la valise html. Quels choix avez vous faits. binary?

le copier sur votre espace web
C’est PRECISEMENT ce que je n’arrive pas à faire : je veins d’essayer avec la bonne vieille méthode “clic-droit-copier-clic-droit-coller” mais le "coller reste désespérément grisé.

Sinon, pour ma connection c’est bon. Je tombe bien sur le bon espace wed; de ce côté pas de pb.

Laurent (merci pour l’aide)

Hello,

Je n’ai jamais expérimenté un problème de ce genre: les dossiers apparaissent mais sont inactifs?

Ma suggestion est de tester avec un client ftp dédié (p.ex. FileZilla pour Windows ou gftp sous GNU/Linux). Si le même phénomène se produit, c’est peut-être un problème de droits sur les répertoires qu’il faudra qu’on voie. Si le transfert (upload) se fait normalement, c’est alors un problème spécifique à Dreamweaver. Réinstallation du logiciel? Réparer la configuration?

Coop,
Greg

sont inactifs?
non, je peux travailler dessus, les lire.

Je vais installer Fille Zilla et tenter d’opérer le transfert avec ce logiciel et vous tiendrais au courant.

Je précise tout de même que mon système d’exploitation ne tourne pas rond. Par exemple depuis peu j’e ne peux plus utiliser Outlook. Il faut que je fasse d’ailleurs un scan antivirus (Avast).

A+
L.

Tout marche comme il faut avec FilleZilla: pourquoi donc pas avec la fonction ftp de Dreamweaver ?
L.

Là, c’est la limite de mes compétences (j’ai pas ma moyenne en divination :wink: )

Si tu passes par Genève, je peux y jeter un œil :slight_smile:
Sinon, il faut réinstaller, ou aller sur les forums de Dreamweaver (as-tu posté à leur support? tu as bien acheté la licence, non?).

Coop,
Greg

J’me suis baladé sur Le Salève d’où je voyais le jet de Genève il y a environ 1 mois…

j’ai réussi à modifier des fichiers de mon site en évitant des les “placer” mais en fermant tout simplement. Mainteant, je ne sais pas si je saurai transférer un fichier de mon disque dur vers le site via Dreamweaver.

Il me faut regarder le guide plus attentivement (ce n’est + du ftp). Merci en tt cas pour les réponse.

Laurent.

Très étrange: après placement de deux fichiers, j’ai accès à la page-index mais mes liens ne marchent pas. Mon site est inutilisable.

Des solutions?

L.

Je précise: une parties de mes liens (situés sur ma page d’accueil fonctionnent tandis que toute une autre partie ne fonctionnent pas.

Comment rétablir le bon fonctionnement ?
L.

As-tu essayé de regarder le code source (il y a 3 onglets dans Dreamweaver, l’un permet de voir le code)? Ça devrait te montrer des liens du genre …/rep/autrefichier.html mais surtout pas file:///C:/Mes Documents/laurent/siteweb/rep/autrefichier.html (qui est un lien relatif à ton disque dur, mais pas au serveur.

Il y a pas mal de tutos qui expliquent tout ça (liens absolus, liens relatifs…). Mais j’ai peut-être complètement faux… Encore une fois, faudrait voir. Tu n’as personne autour de toi qui connaît Dreamweaver et qui peut y jeter un coup d’œil?

Coop,
Greg

C’était effectivement une question de lien relatif qui se mettaient à la place des liens absolus. Il semble que, par certaines de mes procédures (quand j’enregistre, probablement), je perde la maîtrise de la capacité de nommer en lien absolu. Tout est rétabli et marche.

Merci.

L.